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INTRODUCTION 

ProjectWise is an engineering project team collaboration system which is used to help teams improve quality, 

reduce rework, and meet project deadlines. The ProjectWise environment controls files as records in a 

database. ProjectWise will track changes to documents, store attributes for searching and grouping 

documents, control access to documents, create audit trails and manage distributed document locations. From 

any location, the managed ProjectWise environment will always have the same interface. 

MAIN SCREEN 

The ProjectWise Explorer Window has three main sections 

1. The Datasource/Folder View  – left pane 

2. The Document View – right pane 

3. The Preview Pane – bottom of right pane 

The Preview Pane contains several tabs: 

• Folder/Project Properties tabs show their general properties, 

• Document Properties tab shows the general properties when a document is selected, 

• Personal Portal tab allows you to take advantage of custom LEARNing paths and software 

recommendations based on their role and skill level, 

• Dependency Viewer tab shows any known dependencies of a selected document. 

• Photo Preview tab let users preview an image, such as a photograph for image files. 
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ICONS 

 

General ProjectWise Icons include Database Icons, Project /Folder Icons, Document Permission Icons and 

Application Icons. Detailed descriptions are in the following table: 

 

Icons Explanation 

Database 

Icons 

 Datasource: Indicates an individual Datasource. 

 
Active Datasource: Indicates that the Datasource is open and in use 

 Open Datasource : Indicates that the Datasource is open but not in use 

Project 

/Folder 

Icons 

 Project folder: which has more functionalities than Folder. 

 Folder: Indicates folders and subfolders 

 Saved Searches parent folder 

 Save Searches Folder: Each user also has a personal folder 

Document 

Permission 

Icons 

 
Read/Write - The pencil icon indicates that the document is checked in, and you have 

read/write permission for this document 

 
Read Only - The open book icon indicates that you have read-only access to the 

document. 

 

Locked - Document is either checked out, or has been exported, by another user. You can 

still open this document as read-only. 

 Checked Out - Document is checked out to you. 

 
Exported - Document has been exported by you. 

 Final Status of a Document - Someone has set Final Status on this document. 

 
Final Status of a Version - Someone has set Final Status on this version. 

Application 

Icons 

 
The Default icon indicates a document is associated to an application, but the application 

itself has no associated icon. 

 
The Unassociated icon indicates a document not associated to any application, or to one 

that has no file attached. 

 A ProjectWise markup document. 

 The Flat Set icon indicated a document group; several documents grouped together. 

 Represents a logical set for MicroStation. 

 Represents a logical set for AutoCAD. 
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WORKING WITH DOCUMENTS 

• Create Documents 

To create a document, you can copy an existing file from the Windows environment or ProjectWise 

datasource by dragging and dropping, or you can select New Document in ProjectWise similar to 

creating a new document in Windows Explorer.  

No matter drag-drop or New Document, Advanced Wizard is suggested to create new documents. Here 

are the step-by-step instruction for Advanced Wizard: 

1. When Select Target Folder page opens, select the project or folder in which to create the document 

and click Next. 

 

2. The Select a Template page opens for you to select a file or document on which the new document 

will be based.  

a. To create a new document based on an existing ProjectWise document, turn on “Use 

ProjectWise document as a template,” click Select, and select a document from the Select 

Template Document dialog box. If you are dragging an existing ProjectWise document from 

one folder to another, this option and the document you are dragging over will be selected by 

default. 

b. To create a new document based on a file not currently stored in ProjectWise, turn on “Use 

external file as a template,” click Browse, and select the external file to use as your seed file. If 

you are dragging a file in from Windows Explorer, this option and the file you are dragging in 

will be selected by default.  

c. To create a new document by using a file or document that has already been used by the wizard 

to create a new document, turn on “Select from recent used templates” and select the file or 

document to use from the list box. This option is disabled if this is the first time using the wizard. 
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3. When the Define Document Attributes page opens, optionally enter the values in the attribute 

fields and click Next. These attributes will appear on the Attributes tab of the Document Properties 

dialog box. Properly filling out the attributes will help other users identify files and find them 

with the ProjectWise search function. 

 

4. When the Document Properties page opens, enter new or edit existing values for the document 

name, description, file name, and version. All documents must have a unique document name, a 

description, and a unique file name within that folder. Properly filling out the description of the new 

file will help other users identify files and find them with the ProjectWise search function. 
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5. The Create a Document page opens, which displays all the document properties entered during 

the document creation process. To create the document, click Next. When the Completing the 

Advanced Document Creation Wizard page opens, click Finish.  

a. (Optional) To open the newly created document(s) immediately upon completion, turn on 

“Launch associated application.”  

b. (Optional) To apply all the previously selected configuration options to all the succeeding 

documents (if using the wizard to create multiple documents), turn on “Apply selected options 

to succeeding documents,” otherwise the wizard will appear for each document. 

 

 

 

• Check in/ check out 

When a team member wants to edit a file, they check out the file by opening the file (similar to opening 

a file in Windows Explorer). The file is placed in their local working directory and the database record 

is marked checked out to that user and “read only” to all other users. This places the file at the full 

disposal of the user who checked out the file. While the file is checked out, other team members can 

view the file but cannot make any changes.  

When a file is checked in, the file is copied back to the server and the file becomes available for other 

users to check out.  

A user can always refresh the checked out file on the server so that other team members can view or 

reference the latest version. (Right click on file in ProjectWise and select Update Server Copy.)  

Files are automatically checked out when you open them. When you close the file, you will typically be 

prompted to check them back in. However if there is no prompt, go back to the file and right-click and 

select check-in. Also, you can use the Local Document Organizer to check files back in. 
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• Free 

The free command changes the status of a document from checked-out to checked-in without updating 

the server copy. You can only free files that you have checked out. Be careful, any changes made to 

the document will be lost when the document is freed. 

• Delete 

Deleting a file in ProjectWise works similarly to deleting files in Windows Explorer. Select the file, right 

click, and select the Delete option. Should you accidentally delete a file, contact the ProjectWise 

Administrator to have it restored. 

• Rename 

Select the file, right-click, choose Rename. The document name and file name should be the same 

except for the file extension. 

• Version 

Through version control, you can create new documents, based on existing documents, while preserving 

the original document. The original document automatically becomes read-only and the new version is 

now the active document.  

To show all versions or to turn off viewing of older versions go to Tools Menu > Options, select the 

Settings tab and open the Document List option.  

 

 

 

There are three ways to create new version: 

1. Select the file, right-click, select New, then Version. 
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2. When checking in a document, select the “Create new version during Check In” option. 

 

 

 

3. When drag a file with the same file name from outside of ProjectWise into a folder. You must use 

the No Wizard Option. Drag and drop the file into the folder with the existing file. The “Select an 

Action” dialog will appear, select “Create a new version of existing document.” 

 

 

 

• Copy/Move 

There are three ways to copy or move documents: 

1. Copy/Move Files by Dragging Them from One Folder to Another. 

To copy: drag the selected files from the document window into the target folder.  
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To move: press the <Shift> key and drag the selected documents from the document window to the 

target folder. 

2. Copy/Move Documents One at a Time Using the Copy/Move Document Dialog Box. 

Select a document and choose Document > Copy/Move To... The Copy/Move Document dialog box 

opens. 

 

3. Copy/Move Documents using Copy/Cut and Paste. 

Select Document > Copy/Cut. 

Select the folder or project to which you want to move the document(s).  

Select Document > Paste.  

When prompted, Do you want to move document(s) here?, click Yes. 

 

• Export/import 

1. Select one or more documents and choose Document > Export.  

2. The Document Export Wizard opens and click Next.  
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3. Define the export settings page opens. If all of the selected documents are currently exclusively 

checked out or exported, the Export option is disabled and the “Send To Folder” option is 

automatically turned on. There are two ways to export: 

a. Export - Locks File, changes can be re-imported 

The documents will be locked to other users until they are imported back into ProjectWise. 

b. Send to Folder – Create unmanaged local copy 

The documents will still be accessible for other users to edit. 

 

c. Select Next. Click Browse to select the export location, or type the location to which to export 

the document(s) directly in the Export folder field. If this folder does not exist, it will be 

created upon export.  

 

d. Click Next. The documents are exported to the target folder, and the results are displayed in 

the wizard and click Finish. 

4. To import documents, Select one or more exclusively exported documents. Choose Document > 

Import. You can also use the Local Document Organizer to import your documents. 

• Workflow states 

Files that go to the client need to be formatted by document processing so a consistent format is 

maintained. Certain folders will have assigned workflows or states so that a document is protected once 

it has been formatted. These folders are: Correspondence, Deliverables, Meetings and Specifications. 
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When users create a document, the file is automatically given an “In Progress” state. The document can 

be accessed for editing by all users. When the user is ready to have the file formatted and proofed, a link 

to the correct document can be emailed to document processing.  

A document processor will open the file, correct the format, and proofread the file. Then the document 

processor will change the state to “In Document Processing.” At this point, the document will become 

“read only” to engineers.  

If users elect to make edits on the electronic file, they may: Call the document processor and ask them 

to change the state so the file can be edited, or Create a new version of the file and re-email the link to 

document processing so the formatting can be rechecked.  

1. Change Documents State in the Workflow 

Select one or more documents. Choose Document > Change State > Next/ Previous/Change.  

 

2. Setting FINAL Status When File Goes to Client  

FINAL status locks the document and indicates this version is a snapshot of what was sent to the 

client. Be sure it is very clear with the PM who has responsibility to do this (engineer who emails 

document to client, document processor who is told that this document has gone to the client, etc.). 

• Desktop shortcut 

Desktop shortcuts can be created for both folders and files. Simply drag and drop the target folder/file 

to you windows desktop, and this will create a shortcut on Windows desktop.  
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By double clicking the shortcut, it will direct you to the folder/file in ProjectWise. 

 

 

• Share ProjectWise file 

ProjectWise file can be shared by right clicking the file and choosing ‘Send To’. There are two ways to 

send file: Mail Recipient will send out a copy of file as attachment, ‘Mail Recipient As’ Link will send 

out the ProjectWise link of file and recipient can open the link in their ProjectWise Explore. 
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ProjectWise link can also be found in address bar, and it can also be copied and sent by either Copy 

URL or Copy URN. URN uses the document GUID (a unique identifier) and URL uses full folder path. 

PLEASE USE URN WHEN THE FILE LINK CONTAINS SPECIAL CHARACTERS, SUCH AS “®”. 
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• Flat set 

A flat set is a group of documents that are placed into a container for some purpose, such as for printing, 

or to simplify the checkout of multiple documents across folders. When you right-click a flat set, you 

will see all of the options available to you for working with the flat set. When you have a flat set open, 

you can select and right-click the documents in the set and perform actions on them just as you would 

from any folder in ProjectWise Explorer.  

You can place a single document into as many sets as you want. The document is not physically copied 

into the set, but a record of the document is added to the set. Because of this, removing a document from 

a set does not remove the document from the folder in ProjectWise in which it exists.  

When you check out a flat set, all documents in the set are checked out. When you check in a flat set, 

and if you are required to enter change comments upon check in, you are only presented with one Check 

In dialog box in which to enter your comments. 

1. Choose Document > Set > New. The Create Document Set dialog box opens. Type a name and 

optionally a description of the set, and click OK. 

 

2. An empty set window opens for you to add documents. The title bar of the set window shows the 

name of the containing folder followed by the name of the set. Select documents from any folder 

in the datasource and drag them into the set window. 

 

3. Once the first document is added, the flat set is created in ProjectWise, and displays in the 

documents window of the originally selected folder.  
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4. If you close the flat set before adding documents to it, the empty flat set will not be saved to 

ProjectWise. Further, once the last document is removed from a flat set, the empty set is 

automatically deleted. 
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SEARCHES 

You can search on system attributes, on custom attributes, or both. Note that if you search on system attributes 

or on custom attributes, the results of the search will only be as accurate as the data entered by other users. 

• General Search 

Quick Search is a “Google-like” search field available on the new Search toolbar that lets users search 

for documents, folders, and projects, simply by typing the text they want to search by and clicking Start 

search. Quick searches are not case sensitive, and the Quick Search field stores the most recently used 

searches for quick access. 

 

• Search by Form 

Go to Folder>Advanced Search>Search by Form, and fill in the attributes you want to search for, such 

as file name, created by, description, etc. The Search by Form has different tabs listing attributes that 

can be used to base a search on. Available fields are white. Grey fields are unavailable to search on. 

 

Search by Form can also be used to search by text. On Search for Form, select the Full Text tab. In the 

“Look for” field, type the text string you want to search for. To search inside documents’ files for the 

specified text, set “Look inside” to File Contents. Click Apply or OK. 
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• Search Builder 

Go to Folder>Advanced Search>Search Builder. When using the Define Search dialog box, you first 

select the type of search (document or project/folder), then you select what you want to search by. When 

you reach the Value field, depending on the property selected, the Value field either becomes a dropdown 

list box containing fixed options obtained from the datasource, or a text field with an accompanying 

Format (...) button. Just like in the Search by Form dialog box, you can either type in the text field, or 

click the Format button to build a custom search expression. The text you type in search fields may or 

may not be case sensitive, depending on whether or not your administrator has turned on the option in 

the datasource to enforce case sensitivity for searches. Click OK to run the search and close the dialog 

box, or click Apply to run the search but leave the dialog box open. Documents matching your search 

criteria display in the Search Results window. 
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VIEWS 

Views are used to control the properties (in the form of columns) that display in the documents window when 

a folder or project is selected and when View > Details is on. 

• Create and Customize Personal View 

1. Open ProjectWise Explorer>Views> Manage Views, Click “New” and you can custom your view 

here. 

 

2. Enter the name of your personal view, do not change the environment, select the column you want 

and click “left/right arrow” and it will be added to your personal view. You can also sort the order 

of these columns by using the “up/down arrow”. 
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3. If you want to make this as your default view, go to “Set Defaults” tag and check all 4 highlighted 

options. 

 

 

 

4. Click OK and refresh ProjectWise. 
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MAINTENANCE 

• Local Document Organizer 

Local Document Organizer is used to list and manage the documents that you currently have checked 

out, copied out, or exported. Local Document Organizer opens automatically when you log out if you 

still have documents checked out. The Local Document Organizer dialog box always opens with the 

View set to display Checked out Documents. The actions you can perform from the Local Document 

Organizer dialog box depend on the View option that is active. You can select multiple documents in 

the Local Document Organizer’s list box and apply a command to all of them simultaneously. 

 

To avoid ProjectWise slowness, all users are suggested to clean local documents and workspace 

biweekly as below, weekly clean is suggested for heavily used machine, such as CAD drafting. 

 

1. ALL FILES MUST BE SAVED AND CHECKED IN FIRST! 

2. Open ProjectWise Explorer>Tools>Local Document Organizer. The purpose of the Local Document 

Organizer is to manage documents and workspace that have been Checked, Copied, or Exported Out 

to your local drive. 

 

 

 

3. In the open dialog, click Copies icon   and you will see all copies on you laptop, select all copies 

(CTRL + A) or the ones you need to purge, click Purge Copy icon . This will delete local 

document copies. 
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4. In the open dialog, click Workspace Copies icon   and you will see all workspace copies on your 

laptop, select all copies (CTRL + A) or the ones you need to purge, click Purge Copy icon . This 

will delete local workspace copies.  

 

 

 

5. Close Local Document Organizer and refresh ProjectWise. 
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• Changing/Updating ProjectWise Passwords (for external users only)  

In ProjectWise Explorer, go to Tools > Options > Under the General Tab, enter the following 

information:  

Old Password: Enter the assigned (or old) password 

New Password: Enter the newly desired password  

Verify New Password: Re-enter the new password 

Hit Apply or OK to save the new password.  

 

 


